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Визуализаторы

Больше для анализа Больше для иллюстраций

Chimera
rendering

BioBlender
rendering

UnityMol
rendering

Допбаллы: разберите один из инструментов помимо PyMol и напишите по нему туториал на русском 
языке, понятный вашим текущим и будущим коллегам.

PyMol
scripting
rendering

VMD
trajectories
scripting Mol* viewer

web

NGLview
jupyter scripting

Чаще всего визуализаторы используют для, очевидно, визуального анализа 
и для подготовки изображений публикационного качества. Для глубокого 
анализа приходится использовать специализированные инструменты или 
плагины.
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Больше 
возможностей 
для анализа 
в PyMol
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Установка PyMol

1. Пройти на www.pymol.org
2. Нажать на Download Now
3. Выбрать нужную ОС
4. Установить
5. Вернуться на сайт, нажать на Buy 

Licence, выбрать Student/Teacher
6. Лицензия приходит на почту в 

течение пары дней
7. Скачать файл лицензии, указать к 

нему путь при запуске PyMol (или в 
любое другое время Help -> Install 
new License File)
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Загрузка молекулы

File > Open Откроет файл формата pdb, cif (структуры), dsn6, ccp4, mtz (электронные плотности)

File > Get PDB Скачает и откроет структуру и (опционально) электронную плотность

Идентификатор PDB

Как будет называться объект внутри PyMol, содержащий 
информацию о координатах атомов из PDB ID 6XMK 

Можно скачать только какую-то одну цепь

Можно скачать биологическую сборку (assembly). Вкратце, это 
способ существования этой структуры в реальности. Подробнее 
см. следующий практикум.
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Загрузка молекулы (CLI)

fetch 6XMK Скачает 6XMK.cif* в папку, откуда запущен pymol, 
загрузит информацию о координатах в объект 6xmk

fetch 6XMK, my_protein То же, но имя объекта будет my_protein

fetch 6XMK, type=pdb1, multiplex=1 Вместо асимметрической единицы скачает и загрузит 
биологическую сборку

set assembly, 1
fetch 6XMK

fetch 6XMK, type=2fofc Скачает карту электронной плотности** в формате 
ccp4, загрузит в объект 6xmk_2fofc

load <path_to_file>, <some_name> Загрузит информацию из файла в объект с именем 
some_name, тип информации попытается распознать 
из расширения файла

* cif это более новый стандарт для депонирования структур, он более гибкий, чем pdb, но сложен для 
чтения человеком
** Вы так же можете указать fofc. Что вообще значат эти буквы и что за информация содержится в fofc 
карте вы узнаете на лекции про комбинированые синтезы Фурье
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Камера

Приблизить: зажать ПКМ + тянуть мышь на себя
Отдалить: зажать ПКМ + тянуть мышь от себя
Вращение вокруг якорной точки: зажать ЛКМ + водить мышью
Перемещение камеры: зажать СКМ + водить мышью
Близость clipping plane и точки начала “тумана” (fog) к якорной точке: колесико
Изменить якорную точку: щелчок СКМ по любому атому

fogno fog

clipping
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Камера

Якорная точка 
на ближней сфере

Якорная точка 
на дальней сфере
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Сохранить понравившийся ракурс

Ctrl+F{1-12} сохраняет ракурс под номером 1-12. Вернуться к нему можно в 
любой момент нажатием F{1-12} соответственно

Если забыли сочетания мыши и клавиатуры

Подсказка по управлению камерой всегда располагается в нижнем правом углу:
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Правая кнопка мыши: информация об атоме

Щелчок правой кнопкой мыши 
по атому выведет контекстное 
меню с информацией об остатке 
и атоме, слева направо:
● Объект
● Сегмент
● Цепь
● Имя остатка
● Номер остатка
● Имя атома
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Объекты

Можно одновременно работать с несколькими объектами.

Включить/выключить отображение: щелчок по 
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Действия

Большинство имеют очевидные 
названия. Нам в курсе потребуются 
блоки команд 1, 4, 5, 6, 7

1

2
3

4

5
6

7

8
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Отображения

Выберите Wizard > Demo > Representations для наглядной демонстрации всех 
типов отображений в PyMol (кроме nonbonded). 

Включить Выключить

Nonbonded 
вода
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Подписи

Раскраска

Полезные варианты помимо одноцветных:

by element красит все элементы, кроме C, в их цвета по умолчанию. Цвет для C 
можно выбрать из списка.

by chain удобен для быстрого визуального различения цепей

spectrum > rainbow позволяет визуально проследить за ходом цепи от N к C концу

spectrum > b-factors делает раскраску по B-фактору в цветовой схеме по 
умолчанию. Если хочется другую, см. дальше покраску с помощью команд.
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Выделения

Можно задавать отображение и раскраску не всему объекту, а только отдельным 
его частям. Для этого нужно использовать выделения. Простейший способ задать 
выделение – щелкнуть левой кнопкой мыши по атому.

Режим Mouse Mode: Viewing задает возможность 
выделять (щелкните по строчке “3-Button 
Viewing”, чтобы посмотреть, какие еще есть 
режимы)

Режим Selecting определяет, что выделяется при 
щелчке по атому. Щелкните по строчке “Residues”, 
чтобы посмотреть, какие у вас есть опции

Щелчок по другому атому добавляет его (или весь остаток, если выбрано Selecting 
Residues) в выделение. Щелчок по атому, который уже находится в выделении, 
исключает его из выделения.
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Выделения

Маленькие квадраты 
показывают, что находится 
в активном выделении

Активное выделение появляется в меню справа и 
называется sele. Вы заметите, что к названию 
добавлены скобки, чтобы отличить выделение от 
объекта. Чтобы иметь несколько сохраненных 
выделений, можно переименовать sele: A > rename 
selection, тогда все, что будет выбрано мышью потом, 
будет помещаться уже в новый sele.

Альтернативно можно воспользоваться командной 
строкой:
select <selection_name>, <selection_expression>

Например, чтобы сохранить то, что мы выбрали 
мышью:
select his_and_ser, sele

С выделениями можно работать так же, как с 
объектами.

Выбран 
гистидин

Выбран 
гистидин 
и серин
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resi X Все атомы в остатках с номером X

resn X Все атомы в остатках с именем X

chain X Все атомы в цепи X 

name X Все атомы с именем X

id X Все атомы с номером X

X Объект или выделение с именем X

alt X Все атомы, принадлежащие альтлоку X

ss X Все атомы во вторичной структуре 
определенного типа: S бета-лист, H 
альфа-спираль, L+ все остальное

backbone Все атомы остова

sidechain Все атомы боковых радикалов

pepseq X Атомы, принадлежащие пептидной 
последовательности X (в 
однобуквенном коде)

byres X Расширить выделение X до целых 
остатков. Есть и другие “by”-
модификаторы, см. Wiki

X within Y of Z Элементы выделения X в радиусе Y 
от любого элемента выделения Z

Полезный минимум

А также hydrogens, metals, polymer.protein, 
polymer.nucleic и еще много всего полезного. 
Полный список по надобности смотреть тут: 
https://pymolwiki.org/index.php/Selection_Algebra

Выражения можно комбинировать с помощью 
скобок и and, or, not

Также полезно использовать + и -. Так, выражение
resi 10+33-36+40-42 

эквивалентно 
resi 10 or resi 33 or resi 34 or resi 
35 or resi 36 or resi 40 or resi 41 or 
resi 42

Но его гораздо проще записать
17
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Показ 
последовательности

Очень полезная опция. 
Включается по щелчку на S в 
панели внизу справа.

Можно выделять остатки щелчком по 
буквам в последовательности. 

Сейчас в (sele) находятся 
атомы остатков 8, 9 и 10
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Отображения и раскраска (CLI)

show <representation>, <selection or object>
hide <representation>, <selection or object>

color <color>, <selection or object>

Список доступных именных цветов

Сделать свой именной цвет по значениям RGB:
set_color <color name>, [15, 76, 129]

Покраска по B-фактором:
spectrum b, blue_white_red

Можно задавать кастомную цветовую схему, 
минимальное и максимальное значение 
шкалы. См spectrum.
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Задание 1
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fetch 6xmk

hide everything

bg_color white

show cartoon, all

color gray80, element C

color white, chain B

select ligand, chain A and resn 
QYS

select site, byres all within 5 
of ligand

show sticks, ligand

show sticks, site

orient site

set cartoon_side_chain_helper, 1

set cartoon_transparency, 0.5

set ray_trace_mode, 1

ray

Чтобы сделать картинку с прошлого 
слайда, понадобились следующие 
команды и немного манипуляций 
мышкой и GUI

После команд:

Убедитесь, что вы понимаете, что 
делают команды из первых двух 
абзацев 21



Руками я немного подправил 
ракурс, а также перекрасил 
лиганд и добавил подписи. 

Покраска лиганда: 
(ligand) > C > by element > вторая строчка

Подписи:
Щелчок по атому 
серина > (sele) > L > 
residues

Щелчок по атому 
лиганда > (sele) > L > 
residue name

Подписи будут некрасиво наслаиваться на атомы, а еще они мелковаты. 
Задать размер: set label_size, 30
Переместим их: щелчок по режиму Mouse Mode сменит его на Editing. Теперь Ctrl+ЛКМ позволит двигать 
отдельные атомы и подписи. 22



А о чем были последние три настройки?

set cartoon_side_chain_helper, 0 set cartoon_side_chain_helper, 1

Эта настройка при одновременном отображении cartoon и stick скрывает атомы остова. Это позволяет 
сделать картинку чище и читаемей. Ее же можно найти в Setting > Cartoon > Side Chain Helper 

Иногда все же нужно показать какие-то отдельные атомы остова, например, когда они явно участвуют 
в изучаемом феномене. Тогда можно локально скрыть cartoon для конкретного остатка. Общее 
правило для структурных иллюстраций – показывать только то, что нужно для понимания месседжа.
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Transparency

set cartoon_transparency, 0 set cartoon_transparency, 0.5

Прозрачность. Есть варианты выставить прозрачность для каждого типа отображения. 
Для surface нужно просто set_transparency. Можно выставить из меню: Setting > Transparency
Прозрачность часто нужна для разграничения между более важным и менее важным в рамках одной 
иллюстрации. Также прозрачность позволяет одновременно показывать и поверхность белка, и то, что 
под ней находится.
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Ray tracing

Команда draw или File > Export Image As > 
Draw antialiased OpenGL image

Команда ray или File > Export Image As > Ray 
trace with ...

Draw добавляет сглаживание. Ray добавляет тени, текстуру, сглаживание. Больше настроек в Setting > 
Rendering. Никогда не приводите принтскрины в своих отчетах и, тем более, статьях!
Ray и draw могут подготовить изображение нужного размера:
ray 2000 – 2000 пикселей по горизонтали
ray 3440,1440 – 3440 по горизонтали, 1440 по вертикали
После завершения рендеринга File > Export Image As > Capture Current Display 
или команда png <path_to_file.png> 25



Ray tracing

ray_trace_mode, 0

ray_trace_mode, 3ray_trace_mode, 2

ray_trace_mode, 1
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Пространство для творчества

Setting > Edit all показывает все, что можно настроить. 
Примеры того, что можно сделать

Также не забывайте про Tab (автодополнение команды). Esc переключает с вида 
молекулы на терминал. Внутри pymol работают команды bash: pwd, ls, cd...

Полное состояние сцены можно сохранить в виде pymol сессии:
File > Save Session As
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Удачное отображение
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Не очень удачное 
отображение

Много лишнего
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Неудачное отображение
О чем эта история? С чем показаны взаимодействия?
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Неудачное отображение

О чем эта история? Подписи заслонены
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Задание 2, 3, 4
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Загрузка электронной плотности (2fo-fc)

1. Скачать файл в формате DSN6 с сайта PDB, открыть через File > Open или 
через команду load

2. Воспользоваться File > Get PDB…
3. Воспользоваться командой fetch …, type=2fofc
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Volume

6xmk > A > volume > default
Красиво*, но не информативно. Ray не работает на volume’ах - используйте draw. 
Зато видна плотность соседей по кристаллу и границы ячейки, из которой он 
целиком составлен.

*если у вас хорошая видеокарта, поиграйтесь с настройками числа уровней – можно получить очень 
гладкие облачка 34



Mesh

Более информативно отображение 
поверхности уровня в виде сетки (mesh). 
Оно же всегда используется в 
публикациях.

A > mesh > @ level 3.0 показывает 
поверхность уровня 3, т. е. отсекает те 
области пространства, внутри которых Z-
скор плотности выше или равен 3, 
т. е. это ~0.15% самых “плотных” областей.

6XMK довольно хорошая расшифровка, 
и таких областей много, что значит, что 
исходные данные достаточно полны, чтобы 
добиться такого различия между сигналом 
и шумом. 
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Причесываем mesh

Построение mesh через GUI быстро, но грязно – построение идет для всего 
объекта. Иногда хочется добиться более определенного отображения, например, 
показать только ту плотность, по которой в дальнейшем были воссозданы 
координаты только атомов остова. Нам нужна команда isomesh

isomesh <имя будущего объекта>, <исходная карта>, <уровень подрезки>, <выделение>

Построит сетку внутри прямоугольника, задаваемого выделением (для построения 
прямоугольника будут взяты крайние атомы в выделении)

Прямоугольник можно увеличить, добавив аргумент buffer=... 

Чтобы построить сетку не внутри прямоугольника, а непосредственно вокруг 
выделения, нужно добавить аргумент carve=...

Дальше будут примеры!
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isomesh m1, 6xmk_2fofc, 2 isomesh m3, 6xmk_2fofc, 2, ligand, buffer=1

isomesh m2, 6xmk_2fofc, 2, ligand isomesh m2, 6xmk_2fofc, 2, ligand, carve=1
37



Подсказка из PyMol Wiki

carve позволяет сосредоточиться на 
конкретных регионах пространства и сделать 
незаграможденную картинку. Используйте его 
в задании 2! Но будьте осторожны с выбором 
значения – слишком маленькое может 
оставить без рассмотрения области с все еще 
значимой плотностью от изучаемого остатка:

isomesh m2, 6xmk_2fofc, 2, ligand, carve=1 isomesh m2, 6xmk_2fofc, 2, ligand, carve=2
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Пространство для творчества

Ray работает с mesh, но вряд ли вам понравится результат (попробуйте!). Лучше 
использовать draw.

Можно одновременно показать сетки для разных уровней подрезки и покрасить 
их в разные цвета:

Плотность сетки можно увеличить через
map_double 6xmk_2fofc
Следите за RAM!
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Что я сделал:

fetch 2QXI
fetch 2QXI, type=2fofc
fetch 3BSQ
fetch 3BSQ, type=2fofc
hide everything
show cartoon
select loop1, 2qxi and chain A and resi 144-152
select loop2, 3bsq and chain A and resi 138-146
isomesh 2QXI_mesh, 2qxi_2fofc, 2, loop1 and 
backbone, carve=1.5
isomesh 3BSQ_mesh, 3bsq_2fofc, 2, loop2 and 
backbone, carve=1.5
show sticks, loop1 or loop2
set cartoon_transparency, 0.8, loop1 or loop2
color blue, *mesh
bg_color white

orient loop1
disable 3BSQ*
draw

enable 3BSQ*
disable 2QXI*
orient loop2
draw

# я воспользовался показом последовательности, 
чтобы найти соответствующий участок во второй 
структуре – как видите, нумерация различается. 
Альтернативно можно бы было посмотреть на 
последовательность 144-152 в первой структуре и 
сделать select loop2, 3bsq and chain A and pepseq 
TTSPDVTFP

# на самом деле помимо orient я выбирал ракурс 
руками, но вас может устроить и тот, что 
получается с помощью orient

Не забывайте про смену якорной точки и 
настройку fog с помощью колесика


